Smooks JARs locked by Java in Windows

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Smooks JARs locked by Java in Windows

gdimech
This post has NOT been accepted by the mailing list yet.
I am currently using a custom Smooks transformer in Mule ESB. Some classes which are used by this transformer are kept in memory upon shutdown of the app (org.milyn.cdr.SmooksResourceConfiguration, org.milyn.xml.Namespace$SmooksNamespaceMappings). The jar which the classes belong to is locked (milyn-smooks-core-1.5.2.jar) and upon undeployment, the jar is not being removed by mule (this happens only in windows).

I tried using the spring destroy method to clean up the Smooks object, and I've also tried placing the smooks object in registry on startup and removing but both didnt resolve the issue.

The only workaround which is working is copying smooks related jars (milyn-commons, milyn-smooks-core, milyn-smooks-templating) in ${MULE_HOME}/lib/user folder.

The issue here seems to be related to Smooks rather than Mule. Perhaps Smooks is caching objects by default or not releasing a stream?

Any help on this would be appreciated.